
American Innovations (AI) is pleased to announce version 1.6 of our Pipeline Compliance System Axis® 
software (PCS Axis®). This document explains how to install the following items on a user's local computer 
running in a non-client/server environment: 

 Microsoft® SQL Server® Express 2008 R2 SP2 with Tools

 PCS Axis software, job service, and database

 PCS Axis Connection Manager

Topics in this document include those in the following list:

 PCS Axis Best Practices (page 2)

 Installation Requirements (page 9)

 Identifying Your Version of Windows 7 (page 11)

 Downloading and Installing SQL Server Express 2008 R2 SP2 with Tools (page 12)

 Installing PCS Axis (page 13)

 Activating Your PCS Axis License (page 20)

 Activating Your Bridge Import License (page 21)

 Starting PCS Axis Job Service (page 22)

 Product Support and Training (page 25)

If you have questions or need assistance with the installation, contact PCS Technical Services using the 
contact information on page 25.

PCS Axis® v1.6 Single User New Installation (Non-Client/Server) June 2014
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PCS Axis Best Practices is a series of topics demonstrating best practices for setting up the PCS Axis® 
database and related services on a network server running Microsoft® SQL Server® 2008 R2. Topics 
include those in the following list:

 PCS Axis Job Service

 PCS Axis Database (page 4)

 SQL Server (MSSQLServer) Service (page 7)

PCS Axis Job Service

Run the PCS Axis Job Service under a domain account or a SQL Server account with access to the server 
and PCS Axis database. To set up PCS Axis Job Service, follow these steps: 

1 Click the Windows Start button  and navigate to Computer. Right-click Computer and select 
Manage in the shortcut menu to open the Computer Management console (Figure 1). 

2 Double-click Services and Applications in the left pane of the console. Then click Services to 
display a list of services in the middle pane. 

Figure 1.  Computer Management Console
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3 Right-click PCS Axis Job Service 1.6 and select Properties in the shortcut menu to open the 
Properties dialog box (Figure 2). 

4 Click the Log On tab and select the option This account. 

5 Set up PCS Axis Job Service with a user account to log on as a service using a domain account or 
a SQL Server account with access to the server and PCS Axis database. Type the user name and 
password in the appropriate fields (This account, Password, Confirm Password). You can also 
view a list of appropriate user account by clicking Browse > Advanced > Find Now. 

NOTE: The user account must be a member of the Axis_Users group and have access to the 
database server and PCS Axis database. 

6 Click Apply and then OK to close the Properties dialog box and return to the Computer 
Management console. 

7 Click File > Exit to close the Computer Management console. 

Figure 2.  PCS Axis Job Service 1.6 Properties
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PCS Axis Database

Information in this section covers best practices for managing the PCS Axis database using Microsoft® SQL 
Server® Management Studio (SSMS). Topics include those in the following list:

 Setting the Database Owner

 Recommended Autogrowth Setting (page 5)

Setting the Database Owner

To prevent errors from occurring when migrating or restoring the PCS Axis database, or when establishing 
a connection, set the “Owner” of the database using the “sa” account. To set the database “Owner” follow 
these steps: 

1 Start SQL Server Management Studio (SSMS). Click Start > Microsoft SQL Server 2008 R2 > SQL 
Server Management Studio. 

2 Double-click the Databases folder in Object Explorer to open the folder. 

3 Right-click the PCS Axis database and select Properties in the shortcut menu to open the 
Database Properties dialog box (Figure 3). 

4 Select Files in the Select a page navigation panel. 

5 Type sa in the Owner field. Then click OK to save changes and close the dialog box. 

Figure 3.  Database Owner
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Recommended Autogrowth Setting

Information in this section applies to the PCS Axis database and log file. If you are running PCS Axis in a 
client/server network with synchronization, the information also applies to the publication and subscription 
databases. 

Autogrowth indicates how much additional space is allocated when the PCS Axis database and log file 
require more space. Setting Autogrowth properties allow the PCS Axis database and log file to resize 
automatically based on a predetermined percentage. Because the database resizing process is a significant 
drain on computer resources, it is recommended that you set properties in a manner that does not allow 
the database to constantly resize itself. 

NOTE: When using PCS Axis with synchronization, set Autogrowth properties after you create the 
publication and subscription databases. 

To set Autogrowth properties for the database (_dat) and log (_log) files, follow these steps:

1 Start SSMS. Click Start > Microsoft SQL Server 2008 R2 > SQL Server Management Studio.

2 Double-click Databases in Object Explorer. 

3 Right-click the PCS Axis database and select Properties in the shortcut menu to open the Database 
Properties dialog box.

4 Click Files in the Select a page navigation panel (Figure 4). 

Figure 4.  Files - Database Properties
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5 Complete the following steps to set Autogrowth properties for the database (_dat) and log (_log) 
files: 

a Click the … ellipsis button in the Autogrowth column of the database _dat file to open the 
Change Autogrowth dialog box (Figure 5). 

b Click the Enable Autogrowth check box to place a check mark inside the check box. 

c For the File Growth property setting, select the option In Percent and then type 10 in the 
adjacent field. This property setting automatically allocates 10% additional space when the 
database requires more space. 

d Click OK to close the Change Autogrowth dialog box.

e Repeat step 5 for the database _log file. 

f Click OK to close the Database Properties dialog box. Then click File > Exit to exit SSMS. 

Figure 5.  Change Autogrowth
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SQL Server (MSSQLServer) Service

Run the Windows SQL Server (MSSQLSERVER) service under a domain account with access to the PCS 
Axis database. To set up the service, follow these steps: 

1 Click the Windows Start button  and navigate to Computer. Right-click Computer and select 
Manage in the shortcut menu to open the Computer Management console (Figure 6). 

2 Double-click Services and Applications in the left pane of the console. Then click Services to 
display a list of services in the middle pane. 

Figure 6.  Computer Management Console

3 Right-click SQL Server (MSSQLSERVER) and select Properties in the shortcut menu to open the 
Properties dialog box (Figure 7). 

Figure 7.  SQL Server (MSSQLSERVER) Properties
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4 Click the Log On tab and select the option This account. 

5 Set up SQL Server (MSSQLSERVER) with a user account to log on as a service using a domain 
account with access to the PCS Axis database. Type the user name and password in the appropriate 
fields (This account, Password, Confirm Password). You can also view a list of appropriate user 
account by clicking Browse > Advanced > Find Now. 

6 Click Apply and then OK to close the Properties dialog box and return to the Computer 
Management console. 

7 Click File > Exit to close the Computer Management console. 
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Before installing PCS Axis, verify the following items are available and the computer meets the system 
requirements identified in Table 1 (page 10): 

 PCS Axis License File: The installation prompts you for the PCS Axis license file provided by AI.

 Bridge Import License File: If your company purchased the optional Bridge add-on to import 
data from a third-party application, activating Bridge import for operation requires the license file 
provided by AI. 

NOTE: A Bridge license file is not required to import data from Bullhorn® Asset Tracker (BAT™) or 
export data from PCS Axis. You can maintain all PCS Axis licenses for your organization in the same 
shared folder location. PCS Axis will request the file and location the first time each user opens the 
PCS Axis application. The Bridge activation key is assigned only once for the PCS Axis database; 
once it is assigned it functions for all users.

 Microsoft® SQL Server® 2008 R2 SP2 Express with Tools: Before installing PCS Axis on a 
remote client computer, download and install SQL Server Express 2008 R2 SP2 from the Microsoft 
website. The installation provides the database engine required to run PCS Axis as well as database 
management tools, such as SQL Server Management Studio (SSMS). See page 12 for download and 
installation instructions. 

 PCS Axis Installation File: Install PCS Axis using either the installation DVD provided by AI or the 
installation file downloaded from a location identified in an email from PCS Technical Services. 

 System Requirements: Verify the computer meets the system requirements identified in Table 1 
(page 10). 

Installation Requirements
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Table 1.  System Requirements

Properties Minimum Recommended

Processor Intel Core i5 or faster Intel Core i7 or faster

Processor Speed 1.4 GHz or faster 2.0 GHz or faster

RAM 8 GB 16 GB (see note)

Operating System Windows 7 32-bit or 64-bit, 
Service Pack 1 (SP1)

Windows 7 32-bit or 64-bit, 
Service Pack 1 (SP1)

Relational Database 
Software

SQL Server Express 2008 
R2 SP2

SQL Server Express 2008 
R2 SP2

Available Disk Space 10 GB 100 GB

Resolution 1280x1024 1920x1080

Microsoft .NET 
Framework

Version 4 (see note) Version 4 (see note)

NOTES: 

• Larger databases may require more RAM for optimum performance. 

• If the target computer does not have Microsoft® .NET Framework v4.0 installed, the PCS 
Axis installation automatically installs it. This feature requires an active Internet 
connection to complete the installation of .NET Framework v4.0. 

• The installation installs the PCS Axis application, database, and job service on the local 
computer of a single user in a non-client/server network. 
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Information in this section explains how to determine if your computer is running the 32-bit or 64-bit 
version of the Windows 7 operating system. Knowing this information will help you choose the correct 
Microsoft SQL Server Express 2008 R2 SP2 installation file for the PCS Axis installation. 

To determine which version of Windows 7 is running on your computer:

 Click the Windows  Start button and then right-click Computer. Select Properties in the shortcut 
menu to open the System information window (Figure 8). 

Information in the System type field identifies which version of the Windows 7 operating system is 
running on your computer.

Figure 8.  Windows System Information

Identifying Your Version of Windows 7

System Type
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Complete the following steps to download and install SQL Server Express 2008 R2 SP2 with Tools:

1 Visit the Microsoft Download Center at http://www.microsoft.com/download/.

2 Type SQL Server 2008 R2 SP2 Express Edition in the search bar and then click the  search button.

3 Click the link Microsoft® SQL Server® 2008 R2 SP2 - Express Edition to open the product 
download page.

NOTE: Information related to the installation is available when clicking the  expand button for 
any of the following items:  Details, System Requirements, Install Instructions, and Related 
Resources. 

4 Click Download to open a page with a list of files available for download. 

5 If your computer is running the 32-bit version of Windows 7, complete the following steps to 
download and install the installation file labeled SQLEXPRWT_x86_ENU.exe:

a Click the check box for the installation file labeled SQLEXPRWT_x86_ENU.exe. Then click Next 
to begin the download. 

b To install, double-click the SQLEXPRWT_x86_ENU.exe installation file and follow on-screen 
prompts. PCS Axis functions normally with a default installation set up with all default options. 

6 If your computer is running the 64-bit version of Windows 7, complete the following steps to 
download and install the installation file labeled SQLEXPRWT_x64_ENU.exe:

a Click the check box for the installation file labeled SQLEXPRWT_x64_ENU.exe. Then click Next 
to begin the download. 

b To install, double-click the SQLEXPRWT_x64_ENU.exe installation file and follow on-screen 
prompts. PCS Axis functions normally with a default installation set up with all default options. 

Downloading and Installing SQL Server Express 2008 R2 SP2 with Tools
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Information in this section explains how to install PCS Axis on the local computer of a single user in a non-
client/server network. Tasks include those in the following list:

 Install the PCS Axis software and job service.

 Use Connection Manager to connect to an instance of SQL server. 

 Use Connection Manager to install a blank database or select the test database provided with PCS 
Axis. 

NOTE: Connection Manager is a utility software provided with PCS Axis. You can use the utility to 
install a blank database, upgrade an existing database, and create entries for connection settings to 
other PCS Axis databases. 

Complete the following steps: 

1 If you are using the installation DVD to install PCS Axis, insert the DVD in the DVD/CD-ROM drive of 
the computer. Open Windows Explorer to view the contents of the installation DVD.

If you previously downloaded the installation file using a link in an email from PCS Technical 
Services, navigate to the location of the installation file. 

NOTE: A single installation file labeled setup.exe is used to install PCS Axis on a 32-bit and 64-bit 
computer. If the target computer does not have Microsoft .NET Framework v4.0 installed, the PCS 
Axis installation automatically installs it. This feature requires an active Internet connection to 
complete the installation of .NET Framework v4.0. 

2 Double-click the setup.exe installation file to open the PCS Axis dialog box (Figure 9). 

 

Figure 9.  PCS Axis Installation

3 Click Install in the PCS Axis dialog box (Figure 9) to open Setup Wizard (Figure 10, page 14). 

Installing PCS Axis
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4 Click Next to read the End-User License Agreement. To accept the license agreement, click the 
check box I accept the terms in the License Agreement to place a check mark inside the check box. 

 

Figure 10.  Setup Wizard

5 Click Next to display Custom Setup (Figure 11). 

6 By default the  PCS Axis application is selected for installation. Click the down arrow in
 PCS Axis Job Service and select the option Entire feature will be installed on local hard 

drive (Figure 11). 

7 Click Next and then click Install to begin the installation. 

Figure 11.  Custom Setup
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When the installation completes and after a short delay, Connection Manager opens 
automatically on top of Setup Wizard (Figure 12). 

Figure 12.  Connection Manager

8 Complete step "a" or "b" in the Primary group box of Connection Manager to connect to the SQL 
server instance (Figure 12): 

a Type the name of the SQL server instance in the Server field. When entering the name, also 
include the name of the local computer. Use the following format when entering information in 
the Server field:

LocalComputerName\LocalSQLServerInstanceName

– or – 

b Click  Select in the Server field to open the Select Server dialog box (Figure 13, page 16). 
Select the SQL server instance and then click  Close to close the dialog box and return to 
Connection Manager. 

NOTE: The SQL Server Express 2008 R2 installation automatically creates a default server 
instance. The default server instance is identified in the Select Server dialog box with a period 
and also as .\SqlExpress. See the next figure for an example (Figure 13, page 16). 

9 Continue either with step 10 to create and connect to a new empty PCS Axis database or step 11 
(page 18) to connect to the test database provided with PCS Axis. 
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Figure 13.  Select Server

10 Complete the following steps in the Primary group box of Connection Manager to create and 
connect to a new empty PCS Axis database. If needed, you can also use these same steps to create 
a new empty database for training purposes. 

a Type a name for the new database in the Database field and then click  Create/Upgrade. 
When a message displays asking if you want to create the database, click  Yes to begin the 
process. The Create Or Update Database window opens displaying status information during 
the process (Figure 14, page 17). 

b When the message Update Completed displays at the bottom of the Create Or Update 
Database window, click  Close to close the window and return to Connection Manager. 
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Figure 14.  Create Or Update Database

c Click  Test in Connection Manager to verify the connection to the server and database. 
When the message Connection successful displays, click  OK to close the message. 

If the connection to the server and database failed, verify the name of the SQL server instance 
is correct (previously set up in step 8, page 16) and the Windows service labeled SQL Server 
(SQLEXPRESS) is running. To verify the service is running, follow these steps: 

(1) Click the Windows  Start button and then right-click Computer. Select Manage in the 
shortcut menu to open the Windows Computer Management console. 

(2) Open Services and Applications and then click Services. 

(3) Navigate to SQL Server (SQLEXPRESS) and verify Started displays in the Status 
column. If the service is not running, select the service and then click Start in the upper 
left-hand area of the window (Figure 15, page 18). 

(4) Click File > Exit to close Windows Computer Management. 
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Figure 15.  SQL Server (SQLEXPRESS) Service

d In Connection Manager, click  Test to verify the connection to the server and database. If a 
connection cannot be established, contact PCS Technical Services using the contact 
information on page 25. 

e Click  Save and Close to exit Connection Manager. 

f Click Finish in Setup Wizard and then click Close in the PCS Axis dialog box to close the PCS 
Axis installation file (Figure 9, page 13).

g Continue with the next section Activating Your PCS Axis License (page 20).

11 Complete either step "a" or "b" in the Primary group box of Connection Manager (Figure 12, 
page 15) to connect to the test database provided with the PCS Axis software:

a Type pcsappdev in the Database field. This field is not case sensitive. Then continue with 
step "c" (page 19).

- or - 

b Click  Select in the Database field to open the Select Database dialog box (Figure 16, 
page 19). Select PcsAppDev and then click  Close to return to Connection Manager. 
Continue with step "c" (page 19).
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Figure 16.  Select Database

c Click  Test in Connection Manager to verify the connection to the server and database. 
When the message Connection successful displays, click  OK to close the message. 

If the connection to the server and database failed, verify the name of the SQL server instance 
is correct (previously set up in step 8, page 16) and the Windows service labeled SQL Server 
(SQLEXPRESS) is running. To verify the service is running, follow these steps: 

(1) Click the Windows  Start button and then right-click Computer. Select Manage in the 
shortcut menu to open the Windows Computer Management console. 

(2) Open Services and Applications and then click Services. 

(3) Navigate to the SQL Server (SQLEXPRESS) service and verify Started displays in the 
Status column. If the service is not running, select the service and then click Start in the 
upper left-hand area of the window (Figure 15, page 18). 

(4) Click File > Exit to close Windows Computer Management. 

(5) In Connection Manager, click  Test to verify the connection to the server. If a server 
connection cannot be established, contact PCS Technical Services using the contact 
information on page 25. 

d Click  Save and Close to exit Connection Manager. 

e Click Finish in Setup Wizard and then click Close in the PCS Axis dialog box to close the PCS 
Axis installation file (Figure 9, page 13).

f Continue with the next section Activating Your PCS Axis License (page 20).
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Activating the PCS Axis software for operation requires the license file provided by AI at the time you 
purchased the PCS Axis software. If you are unable to locate your license file, contact PCS Technical 
Services for assistance. See the contact information on page 25. 

To activate the PCS Axis software for operation, follow these steps: 

1 Click the Windows  Start button and navigate to the program folder labeled PCS Axis 1.6. Click 
to open the program folder and then click  PCS Axis 1.6 to launch the software. 

2 When the Activation Key message opens, click  OK and then locate and select your PCS Axis 
activation key (Figure 17). 

Figure 17.  Activation Key

3 When the License Agreement window opens, click  I Agree. 

4 Continue the installation with one of the following steps: 

a If your company purchased the optional Bridge add-on, continue with the next section entitled 
Activating Your Bridge Import License (page 21). 

–or–

b If your company did not purchase the optional Bridge add-on, continue with the section 
entitled Starting PCS Axis Job Service (page 22). 

Activating Your PCS Axis License
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If your company purchased the optional Bridge import add-on, running a Bridge import for the first time 
requires you to activate Bridge using the license file provided by AI. 

NOTE: A Bridge license is required only for those operations that use the Basic Bridge function to import 
data. Operations using the Bullhorn Bridge function to import data do not require a Bridge import license. 
Likewise, using Bridge to export data from PCS Axis also does not require a Bridge license.

To activate Bridge import for operation, follow these steps: 

1 If PCS Axis is not running, click Start > PCS Axis to launch the software. Or, click the desktop 
shortcut  PCS Axis if one is available. 

2 Click Tools > Job Service Viewer to open the Job Service Console window (Figure 18).

3 Click Activate Bridge Import License. When the Activation Key dialog box opens, navigate to the 
license file and select it. Then click Open to close the dialog box and return to the Job Service 
Console. 

The message Valid now displays in the License field. If Not Valid is displaying instead, contact PCS 
Technical Services for assistance using the contact information on page 25. 

For information about how to set up and use Bridge, click Tools > Bridge and then click the  help 
button to open a help topic. 

4 Continue the installation with the next section entitled Starting PCS Axis Job Service (page 22)

Figure 18.  Job Service Console

Activating Your Bridge Import License
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The purpose of PCS Axis Job Service is to monitor the PCS Axis job queue, initiating jobs as they become 
available. The following procedure explains how to use Windows Services to start PCS Axis Job Service. 

Complete the following steps: 

1 Click the Windows  Start button and navigate to Computer. Right-click Computer and select 
Manage in the shortcut menu to open the Computer Management console (Figure 19). 

2 Double-click Services and Applications in the left pane of the console. Then click Services to 
display a list of services in the middle pane. 

Figure 19.  Computer Management Console

3 Right-click PCS Axis Job Service 1.6 (Figure 19) and select Properties in the shortcut menu to 
open the Properties dialog box (Figure 20, page 23). 

4 Click the Log On tab and select the option Local System account. Then click the check box Allow 
service to interact with desktop. 

5 Click Apply and then OK to close the Properties dialog box and return to the Computer 
Management console. 

Starting PCS Axis Job Service
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Figure 20.  PCS Axis Job Service 1.6 Properties

6 Select PCS Axis Job Service 1.6 and then click Start (Figure 21). 

7 Click File > Exit to close the Computer Management console. 

Figure 21.  Computer Management Console

8 Start PCS Axis and then click Tools > Job Service Viewer. Verify the message Running displays in 
the Status field (Figure 22, page 24). 

The PCS Axis v1.6 installation is now complete. For information about how to set up and use 
PCS Axis, click the  help button in any window when running the software. Or click Help in 
the main menu of PCS Axis. 
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Figure 22.  Job Service Console

9 Open the About window in PCS Axis to view information about the software and database version. 
Click Help > About PCS Axis to open the About window (Figure 23). 

NOTE: Clicking Copy To Clipboard in the About window copies the following information to the 
Windows clipboard: database connection; software application version; and build information (date 
and time). After copying information to the clipboard, you can then paste it in an email or other 
type of document, such as Microsoft Word. Use this feature when contacting PCS Technical Services 
for support with PCS Axis.

The PCS Axis v1.6 installation is now complete. For information about how to set up and use 
PCS Axis, click the  help button in any window when running the software. Or click Help in 
the main menu of PCS Axis. 

Figure 23.  About PCS Axis
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If you have a suggestion, question, feature request, or a bug to report-your feedback would be 
appreciated. Also if you have a training need for your organization or would like to know more about 
upcoming PCS Axis training classes, please use any of the following contact information to reach PCS 
Technical Services:

Support E-mail: pcstechservices@aiworldwide.com

Support Telephone: 1-800-229-3404 (select 1, then press 2)

American Innovations: http://www.aiworldwide.com

Product Support and Training
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